Вернуться к списку версий

Возможные несовместимости версии 1.2.0 с более ранними

1. Ошибочный параметр $fetch бросает исключение (ранее обрабатывался, как no).

2. Ошибочный плейсхолдер бросает исключение (ранее обрабатывался, как простой ?).

3. Типом плейсхолдера являются алфавитно-цифровые символы после "?", т.е. "SELECT ?qwe FROM" плейсхолдером раньше был "?q", а теперь "?qwe".

4. ?a и ?ai для null-элемента выдают NULL (раньше, соответственно, "" и 0).

5. Несколько изменена иерархия исключений.

6. Изменено поведение декоратора